Hummingbird House The Garden Helper
No-dash-here, you've found The Real Garden Helper! Gardening on the Web since 1997
vine bar
Wild Willy
 

Impatien not blooming! Help!

Gardening Reference » Gardening in 2004
« Prev thread: Immature Common Grackle| Next thread: Impatien Problem! »
Back to Thread index
by Lily789 on August 23, 2004 01:41 AM
I have a New Guinea Impatien that I bought in April of this year. At first it was completely filled with flowers. Within weeks, the flowers gradually decreased in number until around June there were none. Right now, there still are no flowers nor buds. It seems much more interested in growing healthy, green leaves (and vegetative growth) than putting out flowers.

It's in the backyard facing west, so it recieves only a few hours of morning sun. I water and fertilize regularly. It looks healthy except there are NO FLOWERS!

What should I do? I'm frustrated!

Thanks for any help! [Wink]

* * * *
~Lily
by duckie on August 23, 2004 02:08 AM
[wayey] Hi Lily

I had your problem last year.Unless you have really crappy soil,don't use any fertilizer.
Impatiens seem to thrive on neglect.I think it's getting too much nitrogen that makes impatiens look really good,but no blooms.

Happy gardening,
Shari

* * * *
 -
 -
by Lily789 on August 24, 2004 08:06 PM
Hi [wayey] ,
Thanks!

I did fertilize it! I fertilize it along with my other plants. [Embarrassed] Ooops!

* * * *
~Lily

Active Garden Forum

« Prev thread: Immature Common Grackle| Next thread: Impatien Problem! »
Back to Thread index

Other articles you might like: