Hummingbird House The Garden Helper
No-dash-here, you've found The Real Garden Helper! Gardening on the Web since 1997
vine bar
Wild Willy
 

NO blooms on HIBISCUS plant this year... :(

Gardening Reference » Gardening in 2006
« Prev thread: No Blooms on Dahlia| Next thread: no blossoms on apple trees »
Back to Thread index
by MandyinNC on July 11, 2006 03:48 PM
HI! Last year I bought 2 beautiful Hibiscus plants and planted them in our backyard. The continued to bloom all summer long, big white blooms. This year they are HUGE and there are NO blooms at all on them. Can anyone give me any advice on there and if there is anything I can do? Thanks in advance! Mandy
by TulsaRose on July 11, 2006 10:20 PM
Mandy, do you know if you planted the Tropical or Hardy type Hibiscus? In this area, the Hardy ones are just beginning to bloom. The Tropicals bloom here much later, usually around the end of July. That's probably not much help but others can give you more pointers.

* * * *
Rosie z7a
 -
 -
by MandyinNC on July 12, 2006 12:31 AM
Thank you for that info! I am not sure which it is. I am such a novice! Is there a certain type of fertilizer that I should use on these also that would help them?
by dodge on July 12, 2006 01:40 PM
Mine arent blooming yet?

I just planted last year from seed......Have no idea when they bloom??????I am wondering if anyone in zone at 6 or 5 have blooms?????

Hark ......out there..

dodge [lala] [lala] [party]

* * * *
 -
 -
''''Those who live in the Lord Never See Each Other For The Last Time!''''

Active Garden Forum

« Prev thread: No Blooms on Dahlia| Next thread: no blossoms on apple trees »
Back to Thread index

Other articles you might like: